Unknown command for CNM functions

Ask questions or search for answers about CNM here.
New topics: Please search existing topics first. If a new topic is needed, please give it a useful title.

Moderators: dw, hawstom, PhilWill

Unknown command for CNM functions

Postby hawstom » Tue Mar 17, 2009 8:30 am

On two of our machines here we get the error “unknown command” when we try and use CNM functions. I’ve checked the path, menus. Not sure what to do. I don’t think I quite have all the new files I need or something.

Phil Williams, P.E.
Tom
hawstom
Site Admin
 
Posts: 93
Joined: Wed Jan 05, 2005 9:44 pm

Re: Unknown command for CNM functions

Postby hawstom » Tue Mar 17, 2009 8:38 am

Phil,

Here's what needs to happen:

1. You click a button or type a command.
2. AutoCAD looks for (among other possibilities) a defined command "(c:xxxx)" function.
3. Command functions for all the CNM commands should have been defined when the HAWSALIAS.LSP file was loaded by HAWSEDCLOADER.LSP. Any command that doesn't start with HAWS- or HCNM- must be in HAWSALIAS.LSP
4. Commands defined in HAWSALIAS.LSP call the autoloaders in HAWSEDC.LSP.
5. The autoloaders in HAWSEDC.LSP load the individual functions from various files as listed in HAWSEDC.LSP.

If there is an unknown command, I believe what you are calling is not in the HAWSALIAS.LSP that was loaded.

Do this:

Code: Select all
(findfile "hawsalias.lsp")


Then open the file that lisp expression returns, and see if the command you are try to call is in there. I bet it isn't.

Tom
Tom
hawstom
Site Admin
 
Posts: 93
Joined: Wed Jan 05, 2005 9:44 pm


Return to Construction Notes Manager Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron